Vil gerne bede om hjælp :)

Boardets layout og udseende [styles]
clozeit
Indlæg: 9
Tilmeldt: 9. feb 2010 20:18

Vil gerne bede om hjælp :)

Indlæg af clozeit » 17. feb 2010 16:00

Billede

Vil have fjernet de grå felter i fora - det lader til hver andet forum bliver med grå. De skal gøres hvide.

Jeg vil gerne have lavet flere sider på mit forum end bare selve forum-delen, findes der en god guide et sted? Siderne skal selvfølgelig have samme layout(header osv.) med mulighed for selv at skrive i dem. Vil gerne have nogle knapper under logoet.

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1205
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: Vil gerne bede om hjælp :)

Indlæg af jask » 17. feb 2010 19:47

clozeit skrev:Jeg vil gerne have lavet flere sider på mit forum end bare selve forum-delen, findes der en god guide et sted? Siderne skal selvfølgelig have samme layout(header osv.) med mulighed for selv at skrive i dem.
Det er mange forskelligartede spørgsmål i samme emne. Prøv at oprette et indlæg pr. problemstilling, så andre brugere har mulighed for at søge fornuftigt på emneoverskrifter ;)

Jeg svarer lige på det der ligger på den flade hånd.. Du kan oprette statiske sider ved at følge denne vejledning, eller installere ameecks MOD

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1205
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: Vil gerne bede om hjælp :)

Indlæg af jask » 17. feb 2010 21:36

clozeit skrev:Vil have fjernet de grå felter i fora - det lader til hver andet forum bliver med grå. De skal gøres hvide.
Du har naturligvis eksperimenteret med denne: http://www.phpbb.com/community/viewtopi ... orum_pages :?:
Disse to linier

Kode: Vælg alt

.bg1   { background-color: #ECF3F7; }
.bg2   { background-color: #e1ebf2;  }
Jeg skylder at afprøve det selv for at se om der er hold påstandende ;)

clozeit
Indlæg: 9
Tilmeldt: 9. feb 2010 20:18

Re: Vil gerne bede om hjælp :)

Indlæg af clozeit » 18. feb 2010 11:08

Jeg har fået ordnet det meste af ovenstående nu, men tror desværre ikke det .mod er løsningen. Der er simpelthen for lidt kontrol over det :)

Har nu fulgt http://www.phpbb.com/kb/article/add-a-n ... -to-phpbb/ og gjort som der er sagt, altså oprettet en .php og .html fil. Jeg kan se siden i min browser, men kan ikke skrive "æ, ø og å".

<?php
define('IN_PHPBB', true);
$phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './';
$phpEx = substr(strrchr(__FILE__, '.'), 1);
include($phpbb_root_path . 'common.' . $phpEx);

// Start session management
$user->session_begin();
$auth->acl($user->data);
$user->setup('viewtopic');

page_header('Om Ikast KFUM');

$template->set_filenames(array(
'body' => 'omikastkfum_body.html',
));

make_jumpbox(append_sid("{$phpbb_root_path}viewforum.$phpEx"));
page_footer();
?>

Min php fil, er der en fejl? Kører med dansk version 3.0.6

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1205
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: Vil gerne bede om hjælp :)

Indlæg af jask » 18. feb 2010 16:23

Er din html-fil gemt med indkodning UTF8 uden BOM?

clozeit
Indlæg: 9
Tilmeldt: 9. feb 2010 20:18

Re: Vil gerne bede om hjælp :)

Indlæg af clozeit » 18. feb 2010 16:31

jask skrev:Er din html-fil gemt med indkodning UTF8 uden BOM?
Det har jeg netop fået rettet i Notepad++, men det ændrer ikke noget. Får stadig spørgsmålstegn når jeg bruger æ,ø og å. Har prøvet både med og uden "Anvend når ANSI fil åbnes"..

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1205
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: Vil gerne bede om hjælp :)

Indlæg af jask » 18. feb 2010 16:34

clozeit skrev:Går ud fra at den så vil gøre "æ,ø og å" synlige når jeg gemmer/erstatter den gamle fil :)
Det er da et forsøg værd :ugeek:

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1205
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: Vil gerne bede om hjælp :)

Indlæg af jask » 18. feb 2010 16:36

også efter en cachetømning :?:

clozeit
Indlæg: 9
Tilmeldt: 9. feb 2010 20:18

Re: Vil gerne bede om hjælp :)

Indlæg af clozeit » 18. feb 2010 16:41

jask skrev:også efter en cachetømning :?:
Ja, det virker heller ikke efter at jeg har tømt cachen.

Du kan se det her:
Billede

Der er lidt andre problemer også, men leder primært efter en løsning på æ, ø og å-problemet :)

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1205
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: Vil gerne bede om hjælp :)

Indlæg af jask » 18. feb 2010 17:01

Jeg tror på det er et indkodningsproblem:

Se her: http://skovsgaard.net/testboard/minside.php

Besvar