Side 1 af 1

æøå i links (Virker ikke længere)

: 4. maj 2011 10:03
af Stoker
Hej,

Som mange ved understøtter phpBB ikke æøå (bland andet) i links
Jeg er blevet gjort opmærksom på denne: http://area51.phpbb.com/phpBB/viewtopic ... 42#p203967

Derfor en lille guide der fixer dette.

åbn includes/functions.php
Find:

Kode: Vælg alt

return "[a-z]$scheme*:/{2}(?:(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})+|[0-9.]+|\[[a-z0-9.]+:[a-z0-9.]+:[a-z0-9.:]+\])(?::\d*)?(?:/(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Erstat med:

Kode: Vælg alt

return "[a-z][a-z\d+\-.]*:/{2}(?:(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})+|[0-9.]+|\[[a-z0-9.]+:[a-z0-9.]+:[a-z0-9.:]+\])(?::\d*)?(?:/(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?";

Find:

Kode: Vælg alt

return "www\.(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Erstat med:

Kode: Vælg alt

return "www\.(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?";

Find:

Kode: Vælg alt

return "www\.(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Erstat med:

Kode: Vælg alt

return "www\.(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Så skulle links som dette gerne virke: http://olympusæøåteam.dk/

Re: æøå i links

: 4. maj 2011 14:19
af jask
Det må vi strax prøve af her ;) http://olympusæøåteam.dk/

Tak for et supergodt tip, Stoker.

Re: æøå i links

: 4. maj 2011 17:38
af Stoker
Spørgsmålet er bare hvordan vi får det til at virke på links postet før kodeændringen foretages?
Se mit første indlæg, der virker linket ikke.
Jeg tænkte lidt i stil med at reparse bbkoder, men er ikke klar over om det virker på links.

Re: æøå i links

: 4. maj 2011 18:34
af jask
jeg er 100 på at går du ind og vælger rediger for dit indlæg bliver linket genfortolket korrekt når der efterfølgende klikkes på udfør. Men et værktøj der reparser/genfortolker alle links eller indlæg ville naturligvis løse problemet for hele boardet ;)

BBkode reparseren gætter jeg på kun søger efter BBkoderne, jeg kunne godt forestille mig at en reparsing af samtlige indlæg bliver en resourcekrævende operation :roll:

Re: æøå i links

: 20. sep 2012 14:18
af Stoker
Denne virker desværre ikke mere.

Re: æøå i links

: 20. sep 2012 20:46
af Jan
Ærgeligt, post gerne en ny vejledning hvis du støder på en løsning.

Re: æøå i links (Virker ikke længere)

: 30. okt 2012 15:52
af Stoker
En af mine brugere har opdateret koden så det igen virker med æøå.
De kodeændringer der skal til kan ses her: http://www.phpbb3bbcodes.com/viewtopic.php?f=48&t=1169

Re: æøå i links (Virker ikke længere)

: 30. okt 2012 18:01
af Jan
Tak for det, eneste minus er så bare at man skal være bruger for at kunne se det, og tilmelder sig efterlades man med en besked om at man ikke har tilladelse til at se det pgl. forum...

Måske du kan overtales til at poste det her? ;)