æøå i links (Virker ikke længere)

Oversættelse af de kortfattede phpBB3 vejledninger m.m. og brugeres personlige bidrag
Besvar
Brugeravatar
Stoker
Indlæg: 95
Tilmeldt: 20. jun 2008 19:11
Kontakt:

æøå i links (Virker ikke længere)

Indlæg af Stoker » 4. maj 2011 10:03

Hej,

Som mange ved understøtter phpBB ikke æøå (bland andet) i links
Jeg er blevet gjort opmærksom på denne: http://area51.phpbb.com/phpBB/viewtopic ... 42#p203967

Derfor en lille guide der fixer dette.

åbn includes/functions.php
Find:

Kode: Vælg alt

return "[a-z]$scheme*:/{2}(?:(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})+|[0-9.]+|\[[a-z0-9.]+:[a-z0-9.]+:[a-z0-9.:]+\])(?::\d*)?(?:/(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Erstat med:

Kode: Vælg alt

return "[a-z][a-z\d+\-.]*:/{2}(?:(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})+|[0-9.]+|\[[a-z0-9.]+:[a-z0-9.]+:[a-z0-9.:]+\])(?::\d*)?(?:/(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?";

Find:

Kode: Vælg alt

return "www\.(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Erstat med:

Kode: Vælg alt

return "www\.(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?";

Find:

Kode: Vælg alt

return "www\.(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[a-z0-9\-._~!$&'($inline*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[a-z0-9\-._~!$&'($inline*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Erstat med:

Kode: Vælg alt

return "www\.(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})+(?::\d*)?(?:/(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@|]+|%[\dA-F]{2})*)*(?:\?(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?(?:\#(?:[\x80-\xFFa-z0-9\-._~!$&'()*+,;=:@/?|]+|%[\dA-F]{2})*)?";
Så skulle links som dette gerne virke: http://olympusæøåteam.dk/

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1185
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: æøå i links

Indlæg af jask » 4. maj 2011 14:19

Det må vi strax prøve af her ;) http://olympusæøåteam.dk/

Tak for et supergodt tip, Stoker.

Brugeravatar
Stoker
Indlæg: 95
Tilmeldt: 20. jun 2008 19:11
Kontakt:

Re: æøå i links

Indlæg af Stoker » 4. maj 2011 17:38

Spørgsmålet er bare hvordan vi får det til at virke på links postet før kodeændringen foretages?
Se mit første indlæg, der virker linket ikke.
Jeg tænkte lidt i stil med at reparse bbkoder, men er ikke klar over om det virker på links.
Senest rettet af Stoker 17. aug 2012 21:37, rettet i alt 3 gange.

Brugeravatar
jask
Hjemmeside Team Leder
Indlæg: 1185
Tilmeldt: 27. aug 2006 15:36
Geografisk sted: Odense
Kontakt:

Re: æøå i links

Indlæg af jask » 4. maj 2011 18:34

jeg er 100 på at går du ind og vælger rediger for dit indlæg bliver linket genfortolket korrekt når der efterfølgende klikkes på udfør. Men et værktøj der reparser/genfortolker alle links eller indlæg ville naturligvis løse problemet for hele boardet ;)

BBkode reparseren gætter jeg på kun søger efter BBkoderne, jeg kunne godt forestille mig at en reparsing af samtlige indlæg bliver en resourcekrævende operation :roll:

Brugeravatar
Stoker
Indlæg: 95
Tilmeldt: 20. jun 2008 19:11
Kontakt:

Re: æøå i links

Indlæg af Stoker » 20. sep 2012 14:18

Denne virker desværre ikke mere.

Brugeravatar
Jan
Anerkendt medstifter
Indlæg: 878
Tilmeldt: 23. aug 2006 19:01

Re: æøå i links

Indlæg af Jan » 20. sep 2012 20:46

Ærgeligt, post gerne en ny vejledning hvis du støder på en løsning.

Brugeravatar
Stoker
Indlæg: 95
Tilmeldt: 20. jun 2008 19:11
Kontakt:

Re: æøå i links (Virker ikke længere)

Indlæg af Stoker » 30. okt 2012 15:52

En af mine brugere har opdateret koden så det igen virker med æøå.
De kodeændringer der skal til kan ses her: http://www.phpbb3bbcodes.com/viewtopic.php?f=48&t=1169

Brugeravatar
Jan
Anerkendt medstifter
Indlæg: 878
Tilmeldt: 23. aug 2006 19:01

Re: æøå i links (Virker ikke længere)

Indlæg af Jan » 30. okt 2012 18:01

Tak for det, eneste minus er så bare at man skal være bruger for at kunne se det, og tilmelder sig efterlades man med en besked om at man ikke har tilladelse til at se det pgl. forum...

Måske du kan overtales til at poste det her? ;)

Besvar