Fejl ved udsendelse af masse email

Hjælp til installation, indstillinger og funktioner
Preben Nielsen
Indlæg: 9
Tilmeldt: 24. maj 2018 21:03
Geografisk sted: Nordsjælland
Kontakt:

Fejl ved udsendelse af masse email

Indlæg af Preben Nielsen » 24. maj 2018 21:09

Jeg ville udsende en masse-email til alle brugere, men fik 233 sider med denne fejlmeddelelse:

Fejl opstod under dannelse af billede
» Fejl i [ROOT]/phpbb/search/fulltext_native.php i linje 107: Missing argument 8 for phpbb/search/fulltext_native::__construct(), called in [ROOT]/phpbb/cron/task/core/tidy_search.php on line 61 and defined

Hvad er der galt, og hvad kan jeg gøre for at udsende masse-mailen?

Bruger version 3.2.2.

/Preben

Brugeravatar
scootergrisen
Side Administrator
Indlæg: 470
Tilmeldt: 24. feb 2010 13:09
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af scootergrisen » 24. maj 2018 21:45

Selvom du har fået en fejl kan det godt være at e-mailene blev afsendt så tjek om de er afsendt ikke du gør det flere gange.

Du kunne prøve og slette søgeindekset i ACP > Vedligeholdelse > Søgeindeks > phpBB Native Fulltext (aktiv), også oprette det igen og se om det gør nogen forskel.

Preben Nielsen
Indlæg: 9
Tilmeldt: 24. maj 2018 21:03
Geografisk sted: Nordsjælland
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af Preben Nielsen » 24. maj 2018 22:00

Nogle mails er i hvert fald gået igennem, kan jeg konstatere efter at jeg skrev mit indlæg (jeg har selv en ikke-admin-brugerprofil som har modtaget mailen).

1) Hvad er det jeg sletter, hvis jeg gør som du foreslår? Jeg forstår ikke hvad phpBB Native Fulltext (aktiv) viser.

2) Hvordan opretter jeg igen efter sletning?

/Preben

Brugeravatar
scootergrisen
Side Administrator
Indlæg: 470
Tilmeldt: 24. feb 2010 13:09
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af scootergrisen » 24. maj 2018 22:43

Hvis der er 233 brugere i forummet og nogle i hvert fald har fået e-mail så må det vel betyde at der kom den fejl ved dem der har modtaget e-mail.

Det bare søgeindeks. Det bruges vist til at gøre det hurtigere at søge i forummet så er der et indeks over diverse ord vist. Men ikke sikkert det gør nogen forskel det var bare et forslag fordi der stod noget med fulltext_native. Når du har slettet det kommer knappen vist til at hedde Opret... i stedet for Slet....

Der er åbenbart et eller andet billede som bliver genereret i forbindelse med cron som vist er sådan et job der kører opgaver.

Kode: Vælg alt

				// we are writing an image - the user won't see the debug, so let's place it in the log
				if (defined('IMAGE_OUTPUT') || defined('IN_CRON'))
				{
					add_log('critical', 'LOG_IMAGE_GENERATION_ERROR', $errfile, $errline, $msg_text);
				}

Kode: Vælg alt

	'LOG_IMAGE_GENERATION_ERROR'	=> '<strong>Fejl opstod under dannelse af billede</strong><br />» Fejl i %1$s i linie %2$s: %3$s',

Preben Nielsen
Indlæg: 9
Tilmeldt: 24. maj 2018 21:03
Geografisk sted: Nordsjælland
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af Preben Nielsen » 24. maj 2018 22:57

Der er 255 brugere. Og der var 233 SIDER med hver 10-15 linjer med fejl.

Ved ikke hvor meget klogere jeg blev, men vigtigst: Tror du mails er gået igennem? Findes der ikke en log for den slags et sted?

/Preben

Brugeravatar
scootergrisen
Side Administrator
Indlæg: 470
Tilmeldt: 24. feb 2010 13:09
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af scootergrisen » 24. maj 2018 23:17

Hvad mener du med sider?
Åbnede browseren 233 faneblade?
Kan ikke vide om alle har fået e-mail.

Der er logge i ACP > Vedligeholdelse.

Preben Nielsen
Indlæg: 9
Tilmeldt: 24. maj 2018 21:03
Geografisk sted: Nordsjælland
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af Preben Nielsen » 28. maj 2018 13:40

scootergrisen skrev:
24. maj 2018 23:17
Hvad mener du med sider?
Åbnede browseren 233 faneblade?
Nej, men der er i forumet 233 sider, hvor fejlen optræder 25 gange pr. side - MEN som jeg ser det nu, stammer netop denne fejl fra forskellige datoer fra 24/7-2015 til 22/3-2018, og så vidt jeg kan skønne stammer 99% fra en bruger med brugernavnet Anonymous, som figurerer med user_id -1 altså minus 1, som er kommet til før jeg oprettede mig selv ved forumets fødsel.

Ovenover disse er fem linjer med samme fejl:
Email-fejl
» EMAIL/PHP/mail()
/debat/adm/index.php

fra den dato, jeg udsendte masse-emailen. Her kunne jeg gætte på, at det er fejl vedr. 5 mailadresser, men fejlene er ikke specificeret til at handle om bestemte brugere. Så jeg kan ikke vide det.

Men under alle omstændigheder: enten har fejlene vist sig anderledes den dag jeg sendte, eller også har jeg fejllæst.

/Preben

Brugeravatar
scootergrisen
Side Administrator
Indlæg: 470
Tilmeldt: 24. feb 2010 13:09
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af scootergrisen » 28. maj 2018 14:02

Lyder som om den fejl der er 233x25 gange slet ikke har noget med udsendelsen af masse-e-mail at gøre når de er sket på en anden dato.

Jeg har også nogen "Email-fejl" og ved nogen af dem står mere info om "Kunne ikke forbinde til SMTP-vært".

Jeg har også en masse gamle "Email-fejl » EMAIL/PHP/mail() /forum/cron.php" uden mere info.

Står der ikke mere info ved de 5 mail() fejl fra den dato du udsendte masse-e-mail?

Preben Nielsen
Indlæg: 9
Tilmeldt: 24. maj 2018 21:03
Geografisk sted: Nordsjælland
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af Preben Nielsen » 28. maj 2018 14:09

Nej, der står (udover kolonne med Brugernavn, IP-adresse og Tid) kun det jeg skrev (i kolonnen Handling), og der er ikke link, jeg kan klikke på, så der er ikke mere info. Så er der også til højre for Handling en Vælg-kolonne med mulighed for at sætte flueben; den går jeg ud fra kun skal bruges, hvis jeg vil slette linjen.

/Preben

Brugeravatar
scootergrisen
Side Administrator
Indlæg: 470
Tilmeldt: 24. feb 2010 13:09
Kontakt:

Re: Fejl ved udsendelse af masse email

Indlæg af scootergrisen » 28. maj 2018 14:23

Så er der vel ikke så meget mere du kan gøre.
Kan da godt være det har fejlet ved 5 brugere men når fejlbeskeden ikke er bedre kan man vel ikke finde ud af hvilke.
Selv hvis alle e-mail bliver sendt så kan man jo ikke være sikker på de kommer frem alligevel.
Nogen gange får jeg e-mail tilbage fra gmail om at modtagerenes indbakke er fuld eller e-mailadressen ikke findes.
Så kunne du eventuelt skrive den samme tekst som du har sendt i masse e-mail på forummet sådan at alle har mulighed for at se de alligevel selv hvis de ikke skulle havde fået en e-mail eller hvis de har slettet den eller lignende.

Besvar